Stop showing plots in spyder

3679 views python
-1

I have scripts that make lots of plots. I save them directly with plt.savefig() rather than plt.show() so I don't have to close all the windows. In spyder, they all show up in the console if I use inline (meaning I have to scroll way back to see other output), and they all show up in separate windows if I use automatic. I want them to not show up at all, because I'm not calling plt.show() ever. How can I do that?

answered question

2 Answers

2

Try this (assuming imported pyplot as plt), at the start of the code somewhere:

plt.ioff()

posted this
5

Maybe you want to turn spyder support for matplotlib off completely,

Preferences | IPython Consonle | Graphics | Support for Graphics

and untick Activate

enter image description here

posted this

Have an answer?

JD

Please login first before posting an answer.