How to Fix this error Android Studio gradle sync error

1057 views android
-2

plz help me, what is problem in this error.

Could not find com.android.support:appcompat-v7:28.0.0.
Searched in the following locations:
    file:/Users/maneesha/Library/Android/sdk/extras/m2repository/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.pom
    file:/Users/maneesha/Library/Android/sdk/extras/m2repository/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.jar
    file:/Users/maneesha/Library/Android/sdk/extras/google/m2repository/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.pom
    file:/Users/maneesha/Library/Android/sdk/extras/google/m2repository/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.jar
    file:/Users/maneesha/Library/Android/sdk/extras/android/m2repository/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.pom
    file:/Users/maneesha/Library/Android/sdk/extras/android/m2repository/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.jar
    https://jcenter.bintray.com/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.pom
    https://jcenter.bintray.com/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.jar
    https://jcenter.bintray.com/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.pom
    https://jcenter.bintray.com/com/android/support/appcompat-v7/28.0.0/appcompat-v7-28.0.0.jar
Required by:
    project :app

Please install the Android Support Repository from the Android SDK Manager.
Open Android SDK Manager

answered question

as it says.. "Please install the Android Support Repository from the SDK manager"

1 Answer

11

Go to tools->and select SDK manager. This option will open SDK manager. Select the SDK platform and click on checkbox for android pie and select apply and Ok This will download the selected repository. Hope it helps.

posted this

Have an answer?

JD

Please login first before posting an answer.